Download Capabilities Are Down Due To Current GCP Outage

Incident Report for Aryeo

Monitoring

We have identified a workaround the current GCP outage, and the service capabilities have fully recovered. We are monitoring for continued impact.
Posted Jun 12, 2025 - 15:07 EDT

Identified

We are still investigating impact numbers and severity of the issue. We are observing that download capabilities are failing. Part of this infrastructure is powered by Google Cloud, which is experiencing a major outage at this time, and is the root cause of these issues.
Posted Jun 12, 2025 - 15:06 EDT
This incident affects: Media Upload & Download Services.